CVE-2023-30541

TransparentUpgradeableProxy clashing selector calls may not be delegated in @openzeppelin/contracts

MEDIUM
5.3
CVSS Score
Published: April 17, 2023 at 09:37 PM UTC
Updated: June 17, 2026 at 05:54 AM UTC
3 products affected across 1 vendorContractsContracts UpgradeableOpenzeppelin Contracts

Using openzeppelin-contracts by OpenZeppelin?

Get instant alerts when new vulnerabilities affect openzeppelin-contracts - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

OpenZeppelin Contracts is a library for secure smart contract development. A function in the implementation contract may be inaccessible if its selector clashes with one of the proxy's own selectors. Specifically, if the clashing function has a different signature with incompatible ABI encoding, the proxy could revert while attempting to decode the arguments from calldata. The probability of an accidental clash is negligible, but one could be caused deliberately and could cause a reduction in availability. The issue has been fixed in version 4.8.3. As a workaround if a function appears to be inaccessible for this reason, it may be possible to craft the calldata such that ABI decoding does not fail at the proxy and the function is properly proxied through.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.2.0 ≤ v < 4.8.3
Affected range stops below 4.8.3, so it looks safe — our inference, not a vendor statement
3.2.0 ≤ v < 4.8.3
Affected range stops below 4.8.3, so it looks safe — our inference, not a vendor statement
v < 4.8.3
Affected range stops below 4.8.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-436

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card