CVE-2023-28967

Junos OS and Junos OS Evolved: An attacker sending genuine BGP packets causes an RPD crash

HIGH
7.5
CVSS Score
Published: April 17, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:49 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

A Use of Uninitialized Resource vulnerability in the Border Gateway Protocol (BGP) software of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated network-based attacker to send specific genuine BGP packets to a device configured with BGP to cause a Denial of Service (DoS) by crashing the Routing Protocol Daemon (rpd). This issue is triggered when the packets attempt to initiate a BGP connection before a BGP session is successfully established. Continued receipt of these specific BGP packets will cause a sustained Denial of Service condition. This issue is triggerable in both iBGP and eBGP deployments. This issue affects: Juniper Networks Junos OS 21.1 version 21.1R1 and later versions prior to 21.1R3-S5; 21.2 version 21.2R1 and later versions prior to 21.2R3-S2; 21.3 version 21.3R1 and later versions prior to 21.3R3-S2; 21.4 versions prior to 21.4R3; 22.1 versions prior to 22.1R3; 22.2 versions prior to 22.2R2. This issue does not affect Juniper Networks Junos OS versions prior to 21.1R1. This issue affects: Juniper Networks Junos OS Evolved 21.1-EVO version 21.1R1-EVO and later versions prior to 21.4R3-EVO; 22.1-EVO versions prior to 22.1R3-EVO; 22.2-EVO versions prior to 22.2R2-EVO. This issue does not affect Juniper Networks Junos OS Evolved versions prior to 21.1R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 21.1*, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 21.1R1 (unaffected)
Affected range stops below 21.2*, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3*, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R2, so it looks safe — our inference, not a vendor statement
21.1R1-EVO ≤ v < 21.1-EVO*21.4-EVO ≤ v < 21.4R3-EVO22.1-EVO ≤ v < 22.1R3-EVO22.2-EVO ≤ v < 22.2R2-EVO21.1R1-EVO21.4-EVO22.1-EVO22.2-EVO
Affected range stops below 21.1-EVO*, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 21.1R1-EVO (unaffected)
Affected range stops below 21.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-908

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card