CVE-2023-28836

Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views

MEDIUM
5.4
CVSS Score
Published: April 3, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:48 AM UTC
2 products affected across 2 vendorsWagtailWagtail

Using wagtail by wagtail?

Get instant alerts when new vulnerabilities affect wagtail - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.5 ≤ v < 4.1.44.2 ≤ v < 4.2.2
Affected range stops below 4.1.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.2, so it looks safe — our inference, not a vendor statement
v < 4.1.1v < 4.2.21.5 ≤ v < 1.5*4.2 ≤ v < 4.2*1.54.2
Affected range stops below 1.5*, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2*, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.2, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card