CVE-2023-28206

HIGH
8.6
CVSS Score
Published: April 10, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:47 AM UTC
3 products affected across 1 vendormacOSiPhone OSiPadOS

Using iOS and iPadOS by Apple?

Get instant alerts when new vulnerabilities affect iOS and iPadOS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploitation
CISA KEV
Exploit prediction
EPSS 23%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score23.2%

EPSS (Exploit Prediction Scoring System) estimates a 23.2% chance this CVE is exploited in the wild within the next 30 days — higher than 98% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS, iPadOS, and macOS IOSurfaceAccelerator contain an out-of-bounds write vulnerability that allows an app to execute code with kernel privileges.

Required Action
Apply updates per vendor instructions.
Ransomware Use
Unknown
Added to KEV
Apr 10, 2023
Remediation Due
May 1, 2023
1277 days overdue

Description

An out-of-bounds write issue was addressed with improved input validation. This issue is fixed in macOS Monterey 12.6.5, iOS 16.4.1 and iPadOS 16.4.1, macOS Ventura 13.3.1, iOS 15.7.5 and iPadOS 15.7.5, macOS Big Sur 11.7.6. An app may be able to execute arbitrary code with kernel privileges. Apple is aware of a report that this issue may have been actively exploited.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.7v < 15.7.5v < 16.416.0 ≤ v < 16.4.1
Affected range stops below 15.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.7.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.4.1, so it looks safe — our inference, not a vendor statement
v < 15.7.516.0 ≤ v < 16.4.1
Affected range stops below 15.7.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.4.1, so it looks safe — our inference, not a vendor statement
v < 11.7v < 11.7.6v < 12.6v < 13.312.0 ≤ v < 12.6.513.0 ≤ v < 13.3.1
Affected range stops below 11.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.7.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.6.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 13.3.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (6)

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.6HIGHCISA-ADP
Attack Vector
LOCAL
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card