CVE-2023-27477

MEDIUM
4.3
CVSS Score
Published: March 8, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:45 AM UTC
2 products affected across 1 vendorWasmtimeCranelift Codegen

Using wasmtime by bytecodealliance?

Get instant alerts when new vulnerabilities affect wasmtime - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

wasmtime is a fast and secure runtime for WebAssembly. Wasmtime's code generation backend, Cranelift, has a bug on x86_64 platforms for the WebAssembly `i8x16.select` instruction which will produce the wrong results when the same operand is provided to the instruction and some of the selected indices are greater than 16. There is an off-by-one error in the calculation of the mask to the `pshufb` instruction which causes incorrect results to be returned if lanes are selected from the second vector. This codegen bug has been fixed in Wasmtiem 6.0.1, 5.0.1, and 4.0.1. Users are recommended to upgrade to these updated versions. If upgrading is not an option for you at this time, you can avoid this miscompilation by disabling the Wasm simd proposal. Additionally the bug is only present on x86_64 hosts. Other platforms such as AArch64 and s390x are not affected.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

0.84.0 ≤ v < 0.91.10.92.00.93.0
Affected range stops below 0.91.1, so it looks safe — our inference, not a vendor statement
v < 0.91.1v < 0.92.1v < 0.93.1v < 4.0.1v < 5.0.1v < 6.0.10.37.0 ≤ v < 4.0.15.0.06.0.0
Affected range stops below 0.91.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.92.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.93.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-193

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card