CVE-2023-2533

PaperCut MF/NG 22.0.10 (Build 65996 2023-03-27) - Remote code execution via CSRF

HIGH
8.8
CVSS Score
Published: June 20, 2023 at 02:45 PM UTC
Updated: June 17, 2026 at 05:52 AM UTC
2 products affected across 1 vendorPapercut NgPaperCut MF

Using PaperCut NG/MF by PaperCut?

Get instant alerts when new vulnerabilities affect PaperCut NG/MF - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 29%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score28.8%

EPSS (Exploit Prediction Scoring System) estimates a 28.8% chance this CVE is exploited in the wild within the next 30 days — higher than 98% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

PaperCut NG/MF contains a cross-site request forgery (CSRF) vulnerability, which, under specific conditions, could potentially enable an attacker to alter security settings or execute arbitrary code.

Required Action
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Jul 28, 2025
Remediation Due
Aug 18, 2025
437 days overdue

Description

A Cross-Site Request Forgery (CSRF) vulnerability has been identified in PaperCut NG/MF, which, under specific conditions, could potentially enable an attacker to alter security settings or execute arbitrary code. This could be exploited if the target is an admin with a current login session. Exploiting this would typically involve the possibility of deceiving an admin into clicking a specially crafted malicious link, potentially leading to unauthorized changes.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 20.1.821.0.0 ≤ v < 21.2.1222.0.0 ≤ v < 22.1.1
Affected range stops below 20.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1.1, so it looks safe — our inference, not a vendor statement
v < 20.1.821.0.0 ≤ v < 21.2.1222.0.0 ≤ v ≤ 22.1.122.0.10 ≤ v < 2.1.122.0.10
Affected range stops below 2.1.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 20.1.8 (unaffected)
Vendor states this is fixed in 21.2.12 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card