CVE-2023-25173

containerd supplementary groups are not set up properly

HIGH
7.8
CVSS Score
Published: February 16, 2023 at 02:09 PM UTC
Updated: June 17, 2026 at 05:40 AM UTC
2 products affected across 2 vendorsContainerdContainerd

Using containerd by containerd?

Get instant alerts when new vulnerabilities affect containerd - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.5%
SSVC
PoC

Description

containerd is an open source container runtime. A bug was found in containerd prior to versions 1.6.18 and 1.5.18 where supplementary groups are not set up properly inside a container. If an attacker has direct access to a container and manipulates their supplementary group access, they may be able to use supplementary group access to bypass primary group restrictions in some cases, potentially gaining access to sensitive information or gaining the ability to execute code in that container. Downstream applications that use the containerd client library may be affected as well. This bug has been fixed in containerd v1.6.18 and v.1.5.18. Users should update to these versions and recreate containers to resolve this issue. Users who rely on a downstream application that uses containerd's client library should check that application for a separate advisory and instructions. As a workaround, ensure that the `"USER $USERNAME"` Dockerfile instruction is not used. Instead, set the container entrypoint to a value similar to `ENTRYPOINT ["su", "-", "user"]` to allow `su` to properly set up supplementary groups.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.5.181.6.0 ≤ v < 1.6.18
Affected range stops below 1.5.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.6.18, so it looks safe — our inference, not a vendor statement
v < 1.5.18v < 1.6.18
Affected range stops below 1.5.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.6.18, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card