CVE-2023-24814

Persisted Cross-Site Scripting in Frontend Rendering in typo3

MEDIUM
6.1
CVSS Score
Published: February 7, 2023 at 06:14 PM UTC
Updated: June 17, 2026 at 05:39 AM UTC
1 product affected across 1 vendorTYPO3

Using typo3 by TYPO3?

Get instant alerts when new vulnerabilities affect typo3 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.8%
SSVC
PoC

Description

TYPO3 is a free and open source Content Management Framework released under the GNU General Public License. In affected versions the TYPO3 core component `GeneralUtility::getIndpEnv()` uses the unfiltered server environment variable `PATH_INFO`, which allows attackers to inject malicious content. In combination with the TypoScript setting `config.absRefPrefix=auto`, attackers can inject malicious HTML code to pages that have not been rendered and cached, yet. As a result, injected values would be cached and delivered to other website visitors (persisted cross-site scripting). Individual code which relies on the resolved value of `GeneralUtility::getIndpEnv('SCRIPT_NAME')` and corresponding usages (as shown below) are vulnerable as well. Additional investigations confirmed that at least Apache web server deployments using CGI (FPM, FCGI/FastCGI, and similar) are affected. However, there still might be the risk that other scenarios like nginx, IIS, or Apache/mod_php are vulnerable. The usage of server environment variable `PATH_INFO` has been removed from corresponding processings in `GeneralUtility::getIndpEnv()`. Besides that, the public property `TypoScriptFrontendController::$absRefPrefix` is encoded for both being used as a URI component and for being used as a prefix in an HTML context. This mitigates the cross-site scripting vulnerability. Users are advised to update to TYPO3 versions 8.7.51 ELTS, 9.5.40 ELTS, 10.4.35 LTS, 11.5.23 LTS and 12.2.0 which fix this problem. For users who are unable to patch in a timely manner the TypoScript setting `config.absRefPrefix` should at least be set to a static path value, instead of using auto - e.g. `config.absRefPrefix=/`. This workaround **does not fix all aspects of the vulnerability**, and is just considered to be an intermediate mitigation to the most prominent manifestation.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 10.4.36v < 11.5.23v < 12.2.0v < 8.7.51v < 9.5.4010.0.0 ≤ v < 10.4.3611.0.0 ≤ v < 11.5.2312.0.0 ≤ v < 12.2.08.7.0 ≤ v < 9.7.519.0.0 ≤ v < 9.5.40
Affected range stops below 10.4.36, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.5.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.2.0, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.7.51, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.5.40, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.7.51, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card