CVE-2023-23629

Metabase subject to Improper Privilege Management

MEDIUM
6.3
CVSS Score
Published: January 28, 2023 at 01:23 AM UTC
Updated: June 17, 2026 at 05:37 AM UTC
1 product affected across 1 vendorMetabase

Using metabase by metabase?

Get instant alerts when new vulnerabilities affect metabase - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

Metabase is an open source data analytics platform. Affected versions are subject to Improper Privilege Management. As intended, recipients of dashboards subscriptions can view the data as seen by the creator of that subscription. This allows someone with greater access to data to create a dashboard subscription, add people with fewer data privileges, and all recipients of that subscription receive the same data: the charts shown in the email would abide by the privileges of the user who created the subscription. The issue is users with fewer privileges who can view a dashboard are able to add themselves to a dashboard subscription created by someone with additional data privileges, and thus get access to more data via email. This issue is patched in versions 0.43.7.1, 1.43.7.1, 0.44.6.1, 1.44.6.1, 0.45.2.1, and 1.45.2.1. On Metabase instances running Enterprise Edition, admins can disable the "Subscriptions and Alerts" permission for groups that have restricted data permissions, as a workaround.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.43.7.1v < 0.44.6.1v < 0.45.2.1v < 1.43.7.1v < 1.44.6.1v < 1.45.2.10.44.0 ≤ v < 0.44.6.10.45.0 ≤ v < 0.45.2.11.0.0 ≤ v < 1.43.7.11.44.0 ≤ v < 1.44.6.11.45.0 ≤ v < 1.45.2.1
Affected range stops below 0.43.7.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.44.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.45.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.43.7.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.44.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.45.2.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.3MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card