CVE-2023-23613

Field-level security issue with .keyword fields in OpenSearch

MEDIUM
6.5
CVSS Score
Published: January 24, 2023 at 08:33 PM UTC
Updated: June 17, 2026 at 05:37 AM UTC
2 products affected across 2 vendorsOpensearchOpenSearch

Using security by opensearch-project?

Get instant alerts when new vulnerabilities affect security - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.0.0 ≤ v < 1.3.82.0.0 ≤ v < 2.5.0
Affected range stops below 1.3.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.5.0, so it looks safe — our inference, not a vendor statement
v < 1.3.8v < 2.5.0
Affected range stops below 1.3.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.5.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card