CVE-2023-22526

HIGH
8.8
CVSS Score
Published: January 16, 2024 at 05:00 AM UTC
Updated: June 17, 2026 at 05:35 AM UTC
2 products affected across 1 vendorConfluence ServerConfluence Data Center

Using Confluence Data Center by Atlassian?

Get instant alerts when new vulnerabilities affect Confluence Data Center - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%
SSVC
No known exploit

Description

This High severity RCE (Remote Code Execution) vulnerability was introduced in version 7.19.0 of Confluence Data Center. This RCE (Remote Code Execution) vulnerability, with a CVSS Score of 7.2, allows an authenticated attacker to execute arbitrary code which has high impact to confidentiality, high impact to integrity, high impact to availability, and requires no user interaction. Atlassian recommends that Confluence Data Center customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: Confluence Data Center and Server 7.19: Upgrade to a release 7.19.17, or any higher 7.19.x release Confluence Data Center and Server 8.5: Upgrade to a release 8.5.5 or any higher 8.5.x release Confluence Data Center and Server 8.7: Upgrade to a release 8.7.2 or any higher release See the release notes ([https://confluence.atlassian.com/doc/confluence-release-notes-327.html]). You can download the latest version of Confluence Data Center from the download center ([https://www.atlassian.com/software/confluence/download-archives]). This vulnerability was discovered by m1sn0w and reported via our Bug Bounty program

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.19.0 ≤ v < 7.19.178.5.0 ≤ v < 8.5.58.7.0 ≤ v < 8.7.2>= 7.13.0>= 7.19.0>= 8.0.0>= 8.1.0>= 8.2.0>= 8.3.0>= 8.4.0>= 8.5.0>= 8.6.0>= 8.7.1
Vendor states this is fixed in 7.13.0 (unaffected)
Vendor states this is fixed in >= 7.19.17 (unaffected)
Vendor states this is fixed in >= 8.5.5 (unaffected)
Vendor states this is fixed in >= 8.7.2 (unaffected)
7.19 ≤ v < 7.19.178.5.0 ≤ v < 8.5.58.7.0 ≤ v ≤ 8.7.2
Affected range stops below 7.19.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.5.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-94

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card