CVE-2023-22393

Junos OS and Junos OS Evolved: RPD crash upon receipt of BGP route with invalid next-hop

HIGH
7.5
CVSS Score
Published: January 12, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:35 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

An Improper Check for Unusual or Exceptional Conditions vulnerability in BGP route processing of Juniper Networks Junos OS and Junos OS Evolved allows an attacker to cause Routing Protocol Daemon (RPD) crash by sending a BGP route with invalid next-hop resulting in a Denial of Service (DoS). Continued receipt and processing of this packet will create a sustained Denial of Service (DoS) condition. This issue only affects systems without import policy configured. This issue affects: Juniper Networks Junos OS 21.1 versions prior to 21.1R3-S4; 21.2 versions prior to 21.2R3-S3; 21.3 versions prior to 21.3R3-S2; 21.4 versions prior to 21.4R2-S2, 21.4R3; 22.1 versions prior to 22.1R1-S2, 22.1R2; 22.2 versions prior to 22.2R1-S1, 22.2R2. Juniper Networks Junos OS Evolved 21.4-EVO versions prior to 21.4R2-S2-EVO, 21.4R3-EVO; 22.1-EVO versions prior to 22.1R1-S2-EVO, 22.1R2-EVO; 22.2-EVO versions prior to 22.2R1-S1-EVO, 22.2R2-EVO. This issue does not affect: Juniper Networks Junos OS versions prior to 21.1R1. Juniper Networks Junos OS Evolved versions prior to 21.3R1-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 21.1R1 (unaffected)
Affected range stops below 21.1R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R2-S2, 21.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R1-S2, 22.1R2, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R1-S1, 22.2R2, so it looks safe — our inference, not a vendor statement
21.4-EVO ≤ v < 21.4R2-S2-EVO, 21.4R3-EVO22.1-EVO ≤ v < 22.1R1-S2-EVO, 22.1R2-EVO22.2-EVO ≤ v < 22.2R1-S1-EVO, 22.2R2-EVO21.4-EVO22.1-EVO22.2-EVO
Vendor states this is fixed in 21.3R1-EVO (unaffected)
Affected range stops below 21.4R2-S2-EVO, 21.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R1-S2-EVO, 22.1R2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R1-S1-EVO, 22.2R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-358CWE-754

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card