CVE-2023-0668

Wireshark IEEE-C37.118 parsing buffer overflow

MEDIUM
6.5
CVSS Score
Published: June 7, 2023 at 02:32 AM UTC
Updated: June 17, 2026 at 05:26 AM UTC
2 products affected across 2 vendorsDebian LinuxWireshark

Using Wireshark by Wireshark Foundation?

Get instant alerts when new vulnerabilities affect Wireshark - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 2%
SSVC
PoC

Description

Due to failure in validating the length provided by an attacker-crafted IEEE-C37.118 packet, Wireshark version 4.0.5 and prior, by default, is susceptible to a heap-based buffer overflow, and possibly code execution in the context of the process running Wireshark.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.6.0 ≤ v ≤ 3.6.133.6.0 ≤ v < 3.6.144.0.0 ≤ v ≤ 4.0.54.0.0 ≤ v < 4.0.63.6.04.0.0
Vendor states this is fixed in 3.6.14 (unaffected)
Vendor states this is fixed in 4.0.6 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-125CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card