CVE-2023-0507

MEDIUM
5.4
CVSS Score
Published: March 1, 2023 at 03:35 PM UTC
Updated: June 17, 2026 at 05:25 AM UTC
1 product affected across 1 vendorGrafana

Using Grafana by Grafana?

Get instant alerts when new vulnerabilities affect Grafana - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 15%
SSVC
No known exploit

Description

Grafana is an open-source platform for monitoring and observability. Starting with the 8.1 branch, Grafana had a stored XSS vulnerability affecting the core plugin GeoMap. The stored XSS vulnerability was possible due to map attributions weren't properly sanitized and allowed arbitrary JavaScript to be executed in the context of the currently authorized user of the Grafana instance. An attacker needs to have the Editor role in order to change a panel to include a map attribution containing JavaScript. This means that vertical privilege escalation is possible, where a user with Editor role can change to a known password for a user having Admin role if the user with Admin role executes malicious JavaScript viewing a dashboard. Users may upgrade to version 8.5.21, 9.2.13 and 9.3.8 to receive a fix.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

8.1.0 ≤ v < 8.5.219.0.0 ≤ v < 9.2.139.2.0 ≤ v < 9.2.139.3.0 ≤ v < 9.3.88.1.09.0.09.3.0
Affected range stops below 8.5.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.2.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.3.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card