CVE-2023-0458

Spectre V1 Gadget in do_prlimit in the Linux Kernel

MEDIUM
4.7
CVSS Score
Published: April 26, 2023 at 06:03 PM UTC
Updated: June 17, 2026 at 05:25 AM UTC
2 products affected across 2 vendorsLinux KernelDebian Linux

Using Linux Kernel by Linux?

Get instant alerts when new vulnerabilities affect Linux Kernel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.7
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

A speculative pointer dereference problem exists in the Linux Kernel on the do_prlimit() function. The resource argument value is controlled and is used in pointer arithmetic for the 'rlim' variable and can be used to leak the contents. We recommend upgrading past version 6.1.8 or commit 739790605705ddcf18f21782b9c99ad7d53a8c11

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 6.1.8v < 6.1.86.2 rc16.2 rc26.2 rc36.2 rc4
Affected range stops below 6.1.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-476

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card