CVE-2023-0026

2023-06: Out-of-Cycle Security Bulletin: Junos OS and Junos OS Evolved: A BGP session will flap upon receipt of a specific, optional transitive attribute

HIGH
7.5
CVSS Score
Published: June 21, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:24 AM UTC
3 products affected across 2 vendorsJunosJunos OS EvolvedJunos OS Evolved

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

An Improper Input Validation vulnerability in the Routing Protocol Daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, network-based attacker to cause a Denial of Service (DoS). When a BGP update message is received over an established BGP session, and that message contains a specific, optional transitive attribute, this session will be torn down with an update message error. This issue cannot propagate beyond an affected system as the processing error occurs as soon as the update is received. This issue is exploitable remotely as the respective attribute can propagate through unaffected systems and intermediate AS (if any). Continuous receipt of a BGP update containing this attribute will create a sustained Denial of Service (DoS) condition. Some customers have experienced these BGP session flaps which prompted Juniper SIRT to release this advisory out of cycle before fixed releases are widely available as there is an effective workaround. This issue affects: Juniper Networks Junos OS 15.1R1 and later versions prior to 20.4R3-S8; 21.1 version 21.1R1 and later versions prior to 21.2R3-S6; 21.3 versions prior to 21.3R3-S5; 21.4 versions prior to 21.4R3-S4; 22.1 versions prior to 22.1R3-S4; 22.2 versions prior to 22.2R3-S2; 22.3 versions prior to 22.3R2-S2, 22.3R3-S1; 22.4 versions prior to 22.4R2-S1, 22.4R3; 23.1 versions prior to 23.1R1-S1, 23.1R2. Juniper Networks Junos OS Evolved All versions prior to 20.4R3-S8-EVO; 21.1 version 21.1R1-EVO and later versions prior to 21.2R3-S6-EVO; 21.3 versions prior to 21.3R3-S5-EVO; 21.4 versions prior to 21.4R3-S4-EVO; 22.1 versions prior to 22.1R3-S4-EVO; 22.2 versions prior to 22.2R3-S2-EVO; 22.3 versions prior to 22.3R2-S2-EVO, 22.3R3-S1-EVO; 22.4 versions prior to 22.4R2-S1-EVO, 22.4R3-EVO; 23.1 versions prior to 23.1R1-S1-EVO, 23.1R2-EVO.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 15.1R1 (unaffected)
Affected range stops below 20.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.4R3-S8, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1*, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R3-S6, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R3-S5, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R3-S4, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.3R2-S2, 22.3R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.4R2-S1, 22.4R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.1R1-S1, 23.1R2, so it looks safe — our inference, not a vendor statement
v < 20.4R3-S8-EVO21.1R1-EVO ≤ v < 21.1*21.2 ≤ v < 21.2R3-S6-EVO21.3 ≤ v < 21.3R3-S5-EVO21.4 ≤ v < 21.4R3-S4-EVO22.1 ≤ v < 22.1R3-S4-EVO22.2 ≤ v < 22.2R3-S2-EVO22.3 ≤ v < 22.3R2-S2-EVO, 22.3R3-S1-EVO22.4 ≤ v < 22.4R2-S1-EVO, 22.4R3-EVO23.1 ≤ v < 23.1R1-S1-EVO, 23.1R2-EVO21.1R1-EVO21.221.321.422.122.222.322.423.1
Affected range stops below 20.4R3-S8-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.1*, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.2R3-S6-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.3R3-S5-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 21.4R3-S4-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.1R3-S4-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.2R3-S2-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.3R2-S2-EVO, 22.3R3-S1-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 22.4R2-S1-EVO, 22.4R3-EVO, so it looks safe — our inference, not a vendor statement
Affected range stops below 23.1R1-S1-EVO, 23.1R2-EVO, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card