CVE-2022-49280

NFSD: prevent underflow in nfssvc_decode_writeargs()

MEDIUM
5.5
CVSS Score
Published: February 26, 2025 at 01:56 AM UTC
Updated: August 5, 2026 at 09:24 AM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

In the Linux kernel, the following vulnerability has been resolved: NFSD: prevent underflow in nfssvc_decode_writeargs() Smatch complains: fs/nfsd/nfsxdr.c:341 nfssvc_decode_writeargs() warn: no lower bound on 'args->len' Change the type to unsigned to prevent this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.9.3114.10 ≤ v < 4.14.2764.15 ≤ v < 4.19.2384.20 ≤ v < 5.4.1895.11 ≤ v < 5.15.335.12 ≤ v < 5.15.335.12 ≤ v < 5.16.195.12 ≤ v < 5.17.25.12 ≤ v < 5.185.16 ≤ v < 5.16.195.17 ≤ v < 5.17.25.5 ≤ v < 5.10.1105.12a51b5b737a0be93fae6ea2a18df03ab2359a3f4b
Vendor states this is fixed in 184416d4b98509fb4c3d8fc3d6dc1437896cc159 (fixed)
Vendor states this is fixed in 2764af8ce0bf03cc43ee4a11897cab96bde6caae (fixed)
Vendor states this is fixed in 413d8fefafe531a9442bb623e3fe292a38f88d65 (fixed)
Vendor states this is fixed in 614a61e1592051cc42d3c38f899c9f7bdaad8a1d (fixed)
Affected range stops below 4.14.276, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.19.238, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.311, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.10.110, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 5.12 (unaffected)
Vendor states this is fixed in 5.15.33 (unaffected)
Vendor states this is fixed in 5.16.19 (unaffected)
Vendor states this is fixed in 5.17.2 (unaffected)
Vendor states this is fixed in 5.18 (unaffected)
Affected range stops below 5.4.189, so it looks safe — our inference, not a vendor statement

References (9)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.5MEDIUMCISA-ADP
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-191

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card