CVE-2022-4877

snoyberg keter Proxy.hs cross site scripting

MEDIUM
6.1
CVSS Score
Published: January 5, 2023 at 09:14 AM UTC
Updated: June 17, 2026 at 05:22 AM UTC
2 products affected across 2 vendorsKeterProject Keter

Using keter by snoyberg?

Get instant alerts when new vulnerabilities affect keter - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.6%

Description

A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.8.2
Affected range stops below 1.8.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (5)

Issue TrackingPatchThird Party Advisory
https://github.com/snoyberg/keter/pull/246
SignaturePermissions RequiredThird Party Advisory
https://vuldb.com/?ctiid.217444
VDB EntryTechnical DescriptionThird Party Advisory
https://vuldb.com/?id.217444

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card