CVE-2022-48769

efi: runtime: avoid EFIv2 runtime services on Apple x86 machines

MEDIUM
5.5
CVSS Score
Published: June 20, 2024 at 11:13 AM UTC
Updated: June 17, 2026 at 05:16 AM UTC
1 product affected across 1 vendorLinux Kernel

Using Linux by Linux?

Get instant alerts when new vulnerabilities affect Linux - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.2%
SSVC
No known exploit

Description

In the Linux kernel, the following vulnerability has been resolved: efi: runtime: avoid EFIv2 runtime services on Apple x86 machines Aditya reports [0] that his recent MacbookPro crashes in the firmware when using the variable services at runtime. The culprit appears to be a call to QueryVariableInfo(), which we did not use to call on Apple x86 machines in the past as they only upgraded from EFI v1.10 to EFI v2.40 firmware fairly recently, and QueryVariableInfo() (along with UpdateCapsule() et al) was added in EFI v2.00. The only runtime service introduced in EFI v2.00 that we actually use in Linux is QueryVariableInfo(), as the capsule based ones are optional, generally not used at runtime (all the LVFS/fwupd firmware update infrastructure uses helper EFI programs that invoke capsule update at boot time, not runtime), and not implemented by Apple machines in the first place. QueryVariableInfo() is used to 'safely' set variables, i.e., only when there is enough space. This prevents machines with buggy firmwares from corrupting their NVRAMs when they run out of space. Given that Apple machines have been using EFI v1.10 services only for the longest time (the EFI v2.0 spec was released in 2006, and Linux support for the newly introduced runtime services was added in 2011, but the MacbookPro12,1 released in 2015 still claims to be EFI v1.10 only), let's avoid the EFI v2.0 ones on all Apple x86 machines. [0] https://lore.kernel.org/all/[email protected]/

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 3.2.32v ≥ 3.4.14v ≥ 3.5.7v ≥ 3.6.2v < 5.10.963.2.32 ≤ v < 3.33.4.14 ≤ v < 3.53.5.7 ≤ v < 3.63.6.2 ≤ v < 3.73.7 ≤ v < 5.10.963.7 ≤ v < 5.15.193.7 ≤ v < 5.16.53.7 ≤ v < 5.175.11 ≤ v < 5.15.195.16 ≤ v < 5.16.50c9673834740afdfa7c172b1b19c6b3ec5bc390713fcf5d1c5fe491aeb0b0f34a46d88134432edb13.2.323.4.143.5.73.6.23.75.17 rc18e221a3c057d674e3c1cc4d1d8fe65ac4697104bb3ab8b31e8b3c1ff4971bd52d0c8ebde5cfbdb97d6cf86d8f23253225fe2a763d627ecf7dfee9dae
Vendor states this is fixed in 3df52448978802ae15dcebf66beba1029df957b4 (fixed)
Vendor states this is fixed in a4085859411c825c321c9b55b8a9dc5a128a6684 (fixed)
Vendor states this is fixed in b0f1cc093bc2493ac259c53766fd2b800e085807 (fixed)
Vendor states this is fixed in f5390cd0b43c2e54c7cf5506c7da4a37c5cef746 (fixed)
Affected range stops below 3.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.6, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 3.7 (unaffected)
Vendor states this is fixed in 5.10.96 (unaffected)
Vendor states this is fixed in 5.15.19 (unaffected)
Vendor states this is fixed in 5.16.5 (unaffected)
Vendor states this is fixed in 5.17 (unaffected)

References (4)

Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/3df52448978802ae15dcebf66beba1029df957b4
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/a4085859411c825c321c9b55b8a9dc5a128a6684
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/b0f1cc093bc2493ac259c53766fd2b800e085807
Patch
Source: 416baaa9-dc9f-4396-8d5f-8c081fb06d67
https://git.kernel.org/stable/c/f5390cd0b43c2e54c7cf5506c7da4a37c5cef746

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card