CVE-2022-46792

HIGH
8.8
CVSS Score
Published: December 8, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 05:12 AM UTC
1 product affected across 1 vendorGraphql Engine

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.10.0 ≤ v < 2.10.22.11.0 ≤ v < 2.11.32.13.0 ≤ v < 2.13.22.15.0 ≤ v < 2.15.22.12.02.12.0 beta12.14.02.14.0 beta12.14.0 beta2
Affected range stops below 2.10.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.11.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.13.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.15.2, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card