CVE-2022-46258

Incorrect Authorization in GitHub Enterprise Server leads to Action Workflow modifications without Workflow Scope

MEDIUM
6.5
CVSS Score
Published: January 9, 2023 at 12:00 AM UTC
Updated: June 17, 2026 at 05:11 AM UTC
1 product affected across 1 vendorGitHub Enterprise Server

Using GitHub Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect GitHub Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.3.163.3 ≤ v < 3.3.163.4 ≤ v < 3.4.113.4.0 ≤ v < 3.4.113.5 ≤ v < 3.5.83.5.0 ≤ v < 3.5.83.6 ≤ v < 3.6.43.6.0 ≤ v < 3.6.43.33.43.53.6
Affected range stops below 3.3.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.4.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.5.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.6.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.5MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-863

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card