CVE-2022-46172

authentik allows existing authenticated users to create arbitrary accounts

MEDIUM
6.4
CVSS Score
Published: December 28, 2022 at 06:16 AM UTC
Updated: June 17, 2026 at 05:11 AM UTC
1 product affected across 1 vendorAuthentik

Using authentik by goauthentik?

Get instant alerts when new vulnerabilities affect authentik - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.4
Exploit prediction
EPSS 0.6%
SSVC
PoC

Description

authentik is an open-source Identity provider focused on flexibility and versatility. In versions prior to 2022.10.4, and 2022.11.4, any authenticated user can create an arbitrary number of accounts through the default flows. This would circumvent any policy in a situation where it is undesirable for users to create new accounts by themselves. This may also affect other applications as these new basic accounts would exist throughout the SSO infrastructure. By default the newly created accounts cannot be logged into as no password reset exists by default. However password resets are likely to be enabled by most installations. This vulnerability pertains to the user context used in the default-user-settings-flow, /api/v3/flows/instances/default-user-settings-flow/execute/. This issue has been fixed in versions 2022.10.4 and 2022.11.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2022.10.4v < 2022.11.42022.10.0 ≤ v < 2022.10.42022.11.0 ≤ v < 2022.11.4
Affected range stops below 2022.10.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2022.11.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (1)

SSVC — Action Prioritization

SSVCPoCNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

6.4MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-269CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card