CVE-2022-4604

wp-english-wp-admin Plugin english-wp-admin.php register_endpoints cross-site request forgery

HIGH
8.8
CVSS Score
Published: December 18, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 05:21 AM UTC
1 product affected across 1 vendorWp English Wp Admin

Using wp-english-wp-admin Plugin by N/A?

Get instant alerts when new vulnerabilities affect wp-english-wp-admin Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.3%

Description

A vulnerability classified as problematic was found in wp-english-wp-admin Plugin up to 1.5.1. Affected by this vulnerability is the function register_endpoints of the file english-wp-admin.php. The manipulation leads to cross-site request forgery. The attack can be launched remotely. Upgrading to version 1.5.2 is able to address this issue. The name of the patch is ad4ba171c974c65c3456e7c6228f59f40783b33d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216199.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.5.21.5.01.5.1
Affected range stops below 1.5.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-352

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card