CVE-2022-45589

HIGH
7.2
CVSS Score
Published: February 6, 2023 at 12:00 AM UTC
Updated: July 9, 2026 at 01:18 AM UTC
1 product affected across 1 vendorEsb Runtime

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

All versions before 8.0.1-R2022-10-RT and 7.3.1-R2022-09-RT of the Talend ESB Runtime are potentially vulnerable to SQL Injection attacks in the provisioning service only. Users of the provisioning service should upgrade to either 8.0.1-R2022-10-RT or 7.3.1-R2022-09-RT or a later release and use it in place of the previous version.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 7.3.1-r2022-09-rt8.0 ≤ v < 8.0.1-r2022-10-rt
Affected range stops below 7.3.1-r2022-09-rt, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.0.1-r2022-10-rt, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.2HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-89

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card