CVE-2022-45151

MEDIUM
5.4
CVSS Score
Published: November 23, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 05:09 AM UTC
3 products affected across 2 vendorsFedoraMoodleMoodle

Using Moodle by N/A?

Get instant alerts when new vulnerabilities affect Moodle - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.7%
SSVC
No known exploit

Description

The stored-XSS vulnerability was discovered in Moodle which exists due to insufficient sanitization of user-supplied data in several "social" user profile fields. An attacker could inject and execute arbitrary HTML and script code in user's browser in context of vulnerable website.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.11.0 ≤ v < 3.11.114.0.0 ≤ v < 4.0.5
Affected range stops below 3.11.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.5, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 4.0.5 (unaffected)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.4MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card