CVE-2022-44748

Uploading workflows to KNIME Server may override arbitrary file system contents

HIGH
7.5
CVSS Score
Published: November 24, 2022 at 06:36 AM UTC
Updated: June 17, 2026 at 05:08 AM UTC
1 product affected across 1 vendorKNIME Server

Using KNIME Server by KNIME?

Get instant alerts when new vulnerabilities affect KNIME Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

A directory traversal vulnerability in the ZIP archive extraction routines of KNIME Server since 4.3.0 can result in arbitrary files being overwritten on the server's file system. This vulnerability is also known as 'Zip-Slip'. An attacker can create a KNIME workflow that, when being uploaded, can overwrite arbitrary files that the operating system user running the KNIME Server process has write access to. The user must be authenticated and have permissions to upload files to KNIME Server. This can impact data integrity (file contents are changed) or cause errors in other software (vital files being corrupted). It can even lead to remote code execution if executable files are being replaced and subsequently executed by the KNIME Server process user. In all cases the attacker has to know the location of files on the server's file system, though. Note that users that have permissions to upload workflows usually also have permissions to run them on the KNIME Server and can therefore already execute arbitrary code in the context of the KNIME Executor's operating system user. There is no workaround to prevent this vulnerability from being exploited. Updates to fixed versions 4.13.6, 4.14.3, or 4.15.3 are advised.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.14.0 ≤ v < 4.14.34.15.0 ≤ v < 4.15.34.3.0 ≤ v < 4.13.64.14.04.15.04.3.0
Affected range stops below 4.13.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.14.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.15.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card