CVE-2022-44635

Apache Fineract allowed an authenticated user to perform remote code execution due to path traversal

HIGH
8.8
CVSS Score
Published: November 29, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 05:08 AM UTC
1 product affected across 1 vendorFineract

Using Apache Fineract by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Fineract - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 69%
SSVC
No known exploit

Description

Apache Fineract allowed an authenticated user to perform remote code execution due to a path traversal vulnerability in a file upload component of Apache Fineract, allowing an attacker to run remote code. This issue affects Apache Fineract version 1.8.0 and prior versions. We recommend users to upgrade to 1.8.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.8.1Apache Fineract 1.7 ≤ v ≤ 1.7.0Apache Fineract 1.8 ≤ v ≤ 1.8.01.71.8
Affected range stops below 1.8.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card