CVE-2022-4290

Cyr to Lat <= 3.5 - Authenticated SQL Injection

HIGH
8.8
CVSS Score
Published: October 20, 2023 at 07:29 AM UTC
Updated: June 17, 2026 at 05:20 AM UTC
3 products affected across 3 vendorsCyr To LatCyr to Lat EnhancedCyr to Lat Enhanced

Using Cyr to Lat enhanced by karevn?

Get instant alerts when new vulnerabilities affect Cyr to Lat enhanced - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.8%
SSVC
No known exploit

Description

The Cyr to Lat plugin for WordPress is vulnerable to authenticated SQL Injection via the 'ctl_sanitize_title' function in versions up to, and including, 3.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This potentially allows authenticated users with the ability to add or modify terms or tags to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. A partial patch became available in version 3.6 and the issue was fully patched in version 3.7.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.7
Affected range stops below 3.7, so it looks safe — our inference, not a vendor statement
v ≤ 3.5
60%
v ≤ 3.5

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHWordfence
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-89

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card