CVE-2022-41946

TemporaryFolder on unix-like systems does not limit access to created files in pgjdbc

MEDIUM
5.5
CVSS Score
Published: November 23, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 05:04 AM UTC
3 products affected across 3 vendorsDebian LinuxPostgreSQL Jdbc DriverPgJDBC

Using pgjdbc by pgjdbc?

Get instant alerts when new vulnerabilities affect pgjdbc - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.5%

Description

pgjdbc is an open source postgresql JDBC Driver. In affected versions a prepared statement using either `PreparedStatement.setText(int, InputStream)` or `PreparedStatemet.setBytea(int, InputStream)` will create a temporary file if the InputStream is larger than 2k. This will create a temporary file which is readable by other users on Unix like systems, but not MacOS. On Unix like systems, the system's temporary directory is shared between all users on that system. Because of this, when files and directories are written into this directory they are, by default, readable by other users on that same system. This vulnerability does not allow other users to overwrite the contents of these directories or files. This is purely an information disclosure vulnerability. Because certain JDK file system APIs were only added in JDK 1.7, this this fix is dependent upon the version of the JDK you are using. Java 1.7 and higher users: this vulnerability is fixed in 4.5.0. Java 1.6 and lower users: no patch is available. If you are unable to patch, or are stuck running on Java 1.6, specifying the java.io.tmpdir system environment variable to a directory that is exclusively owned by the executing user will mitigate this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

42.2.0 ≤ v < 42.2.2742.3.0 ≤ v < 42.3.842.4.0 ≤ v < 42.4.342.5.042.5.0 rc1
Affected range stops below 42.2.27, so it looks safe — our inference, not a vendor statement
Affected range stops below 42.3.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 42.4.3, so it looks safe — our inference, not a vendor statement
v < 42.2.27v < 42.3.8v < 42.4.3v < 42.5.1
Affected range stops below 42.2.27, so it looks safe — our inference, not a vendor statement
Affected range stops below 42.3.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 42.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 42.5.1, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200CWE-377CWE-668

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card