CVE-2022-41617

BIG-IP Advanced WAF and ASM iControl REST vulnerability CVE-2022-41617

HIGH
7.2
CVSS Score
Published: October 19, 2022 at 09:19 PM UTC
Updated: June 17, 2026 at 05:03 AM UTC
2 products affected across 1 vendorBig IP Application Security ManagerBig IP Advanced Web Application Firewall

Using BIG-IP Advanced WAF & ASM by F5?

Get instant alerts when new vulnerabilities affect BIG-IP Advanced WAF & ASM - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

In versions 16.1.x before 16.1.3.1, 15.1.x before 15.1.6.1, 14.1.x before 14.1.5.1, and 13.1.x before 13.1.5.1, When the Advanced WAF / ASM module is provisioned, an authenticated remote code execution vulnerability exists in the BIG-IP iControl REST interface.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

13.1.0 ≤ v < 13.1.5.113.1.x ≤ v < 13.1.5.114.1.0 ≤ v < 14.1.5.114.1.x ≤ v < 14.1.5.115.1.0 ≤ v < 15.1.6.115.1.x ≤ v < 15.1.6.116.1.0 ≤ v < 16.1.3.116.1.x ≤ v < 16.1.3.113.1.x14.1.x15.1.x16.1.x
Affected range stops below 13.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1.3.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 17.0.0 (unaffected)
13.1.0 ≤ v < 13.1.5.113.1.x ≤ v < 13.1.5.114.1.0 ≤ v < 14.1.5.114.1.x ≤ v < 14.1.5.115.1.0 ≤ v < 15.1.6.115.1.x ≤ v < 15.1.6.116.1.0 ≤ v < 16.1.3.116.1.x ≤ v < 16.1.3.113.1.x14.1.x15.1.x16.1.x
Affected range stops below 13.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1.3.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 17.0.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.2HIGHf5
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-77

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card