CVE-2022-41240

MEDIUM
5.4
CVSS Score
Published: September 21, 2022 at 03:45 PM UTC
Updated: June 17, 2026 at 05:02 AM UTC
1 product affected across 1 vendorWalti

Using Jenkins Walti Plugin by Jenkins project?

Get instant alerts when new vulnerabilities affect Jenkins Walti Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 0.6%
SSVC
No known exploit

Description

Jenkins Walti Plugin 1.0.1 and earlier does not escape the information provided by the Walti API, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to provide malicious API responses from Walti.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Walti· Jenkinsjenkins-plugin
95%
v ≤ 1.0.1
Vendor states this is fixed in next of 1.0.1 (unknown)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.4MEDIUMCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card