CVE-2022-39280

Regular expression denial of service in dparse

HIGH
7.5
CVSS Score
Published: October 6, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:58 AM UTC
2 products affected across 2 vendorsDependency ParserDependency Parser

Using dparse by pyupio?

Get instant alerts when new vulnerabilities affect dparse - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 1%
SSVC
No known exploit

Description

dparse is a parser for Python dependency files. dparse in versions before 0.5.2 contain a regular expression that is vulnerable to a Regular Expression Denial of Service. All the users parsing index server URLs with dparse are impacted by this vulnerability. A patch has been applied in version `0.5.2`, all the users are advised to upgrade to `0.5.2` as soon as possible. Users unable to upgrade should avoid passing index server URLs in the source file to be parsed.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 0.5.1
Affected range stops below 0.5.1, so it looks safe — our inference, not a vendor statement
v < 0.5.2
Affected range stops below 0.5.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400CWE-1333

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card