CVE-2022-39231

Parse Server subject to Improper Authentication allowing Auth adapter app ID validation to be circumvented

LOW
3.7
CVSS Score
Published: September 23, 2022 at 07:40 AM UTC
Updated: June 17, 2026 at 04:57 AM UTC
2 products affected across 2 vendorsParse ServerParse Server

Using parse-server by parse-community?

Get instant alerts when new vulnerabilities affect parse-server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.7
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 4.10.16, or from 5.0.0 to 5.2.6, validation of the authentication adapter app ID for _Facebook_ and _Spotify_ may be circumvented. Configurations which allow users to authenticate using the Parse Server authentication adapter where `appIds` is set as a string instead of an array of strings authenticate requests from an app with a different app ID than the one specified in the `appIds` configuration. For this vulnerability to be exploited, an attacker needs to be assigned an app ID by the authentication provider which is a sub-set of the server-side configured app ID. This issue is patched in versions 4.10.16 and 5.2.7. There are no known workarounds.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.10.165.0.0 ≤ v < 5.2.7
Affected range stops below 4.10.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.7, so it looks safe — our inference, not a vendor statement
v < 4.10.16v < 5.2.7
Affected range stops below 4.10.16, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.7LOWGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card