CVE-2022-36108

Cross-Site Scripting in typo3/cms-core

MEDIUM
6.1
CVSS Score
Published: September 13, 2022 at 05:20 PM UTC
Updated: June 17, 2026 at 04:52 AM UTC
1 product affected across 1 vendorTYPO3

Using typo3 by TYPO3?

Get instant alerts when new vulnerabilities affect typo3 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

TYPO3 is an open source PHP based web content management system released under the GNU GPL. It has been discovered that the `f:asset.css` view helper is vulnerable to cross-site scripting when user input is passed as variables to the CSS. Update to TYPO3 version 10.4.32 or 11.5.16 that fix the problem. There are no known workarounds for this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
v < 10.4.32v < 11.5.1610.0.0 ≤ v ≤ 10.4.3111.0.0 ≤ v ≤ 11.5.15
Affected range stops below 10.4.32, so it looks safe — our inference, not a vendor statement
Affected range stops below 11.5.16, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card