CVE-2022-3602

X.509 Email Address 4-byte Buffer Overflow

HIGH
7.5
CVSS Score
Published: November 1, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:59 AM UTC
10 products affected across 5 vendorsFedoraOpenSSLNode.js

Using OpenSSL by OpenSSL?

Get instant alerts when new vulnerabilities affect OpenSSL - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 91%
SSVC
No known exploit

Description

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed the malicious certificate or for the application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address to overflow four attacker-controlled bytes on the stack. This buffer overflow could result in a crash (causing a denial of service) or potentially remote code execution. Many platforms implement stack overflow protections which would mitigate against the risk of remote code execution. The risk may be further mitigated based on stack layout for any given platform/compiler. Pre-announcements of CVE-2022-3602 described this issue as CRITICAL. Further analysis based on some of the mitigating factors described above have led this to be downgraded to HIGH. Users are still encouraged to upgrade to a new version as soon as possible. In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects. Fixed in OpenSSL 3.0.7 (Affected 3.0.0,3.0.1,3.0.2,3.0.3,3.0.4,3.0.5,3.0.6).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

18.0.0 ≤ v < 18.11.018.12.019.0.0
Affected range stops below 18.11.0, so it looks safe — our inference, not a vendor statement
3.0.0 ≤ v < 3.0.7
Vendor states this is fixed in 3.0.7 (unaffected)
V2022.4 ≤ v < V2023.12022.4
Affected range stops below V2023.1, so it looks safe — our inference, not a vendor statement
V5.2.1 ≤ v < V5.3.05.2.1
Affected range stops below V5.3.0, so it looks safe — our inference, not a vendor statement
V3.2.7 ≤ v < V3.2.83.2.7
Affected range stops below V3.2.8, so it looks safe — our inference, not a vendor statement
V3.2.7 ≤ v < V3.2.83.2.7
Affected range stops below V3.2.8, so it looks safe — our inference, not a vendor statement
V1.80 ≤ v < V2.201.80
Affected range stops below V2.20, so it looks safe — our inference, not a vendor statement
V2.13.0.0 ≤ v < V2.13.0.32.13.0.0
Affected range stops below V2.13.0.3, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card