CVE-2022-35977

Integer overflow in certain command arguments can drive Redis to OOM panic

MEDIUM
5.5
CVSS Score
Published: January 20, 2023 at 06:19 PM UTC
Updated: June 17, 2026 at 04:52 AM UTC
1 product affected across 1 vendorRedis

Using redis by redis?

Get instant alerts when new vulnerabilities affect redis - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 13%
SSVC
No known exploit

Description

Redis is an in-memory database that persists on disk. Authenticated users issuing specially crafted `SETRANGE` and `SORT(_RO)` commands can trigger an integer overflow, resulting with Redis attempting to allocate impossible amounts of memory and abort with an out-of-memory (OOM) panic. The problem is fixed in Redis versions 7.0.8, 6.2.9 and 6.0.17. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.0.17v < 6.2.9v < 7.0.86.0.0 ≤ v < 6.0.176.2.0 ≤ v < 6.2.97.0.0 ≤ v < 7.0.8
Affected range stops below 6.0.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.0.8, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (6)

x_refsource_MISCRelease NotesThird Party Advisory
https://github.com/redis/redis/releases/tag/6.0.17
x_refsource_MISCRelease NotesThird Party Advisory
https://github.com/redis/redis/releases/tag/6.2.9
x_refsource_MISCRelease NotesThird Party Advisory
https://github.com/redis/redis/releases/tag/7.0.8
Source: af854a3a-2127-422b-91ae-364da2661108
https://lists.debian.org/debian-lts-announce/2024/11/msg00031.html

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

5.5MEDIUMGitHub_M
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-190

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card