CVE-2022-35653

MEDIUM
6.1
CVSS Score
Published: July 25, 2022 at 03:33 PM UTC
Updated: June 17, 2026 at 04:52 AM UTC
4 products affected across 3 vendorsFedoraEnterprise LinuxMoodle

Using Moodle by N/A?

Get instant alerts when new vulnerabilities affect Moodle - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 5%

Description

A reflected XSS issue was identified in the LTI module of Moodle. The vulnerability exists due to insufficient sanitization of user-supplied data in the LTI module. A remote attacker can trick the victim to follow a specially crafted link and execute arbitrary HTML and script code in user's browser in context of vulnerable website to steal potentially sensitive information, change appearance of the web page, can perform phishing and drive-by-download attacks. This vulnerability does not impact authenticated users.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.11.0 ≤ v < 3.11.83.9.0 ≤ v < 3.9.154.0.04.0.0 beta4.0.0 rc14.0.0 rc24.0.0 rc34.0.0 rc44.0.1
Affected range stops below 3.11.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.15, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 4.0.2 (unaffected)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card