CVE-2022-32893

HIGH
8.8
CVSS Score
Published: August 24, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:48 AM UTC
8 products affected across 5 vendorsmacOSDebian LinuxFedora

Using Safari by Apple?

Get instant alerts when new vulnerabilities affect Safari - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploitation
CISA KEV
Exploit prediction
EPSS 10%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score9.9%

EPSS (Exploit Prediction Scoring System) estimates a 9.9% chance this CVE is exploited in the wild within the next 30 days — higher than 96% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Apple iOS and macOS contain an out-of-bounds write vulnerability that could allow for remote code execution when processing malicious crafted web content.

Required Action
Apply updates per vendor instructions.
Ransomware Use
Unknown
Added to KEV
Aug 18, 2022
Remediation Due
Sep 8, 2022
1512 days overdue

Description

An out-of-bounds write issue was addressed with improved bounds checking. This issue is fixed in iOS 15.6.1 and iPadOS 15.6.1, macOS Monterey 12.5.1, Safari 15.6.1. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 15.6v < 15.6.1
Affected range stops below 15.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.6.1, so it looks safe — our inference, not a vendor statement
v < 15.6.1
Affected range stops below 15.6.1, so it looks safe — our inference, not a vendor statement
v < 12.512.0 ≤ v < 12.5.1
Affected range stops below 12.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 12.5.1, so it looks safe — our inference, not a vendor statement
v < 15.6v < 15.6.1
Affected range stops below 15.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.6.1, so it looks safe — our inference, not a vendor statement
v < 2.36.7
Affected range stops below 2.36.7, so it looks safe — our inference, not a vendor statement
v < 2.36.7
Affected range stops below 2.36.7, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCActiveNot automatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

8.8HIGHCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card