CVE-2022-31186

Leakage of excessive information into log in next-auth

LOW
3.3
CVSS Score
Published: August 1, 2022 at 07:25 PM UTC
Updated: June 17, 2026 at 04:44 AM UTC
2 products affected across 2 vendorsNextauth.jsJs Next Auth

Using next-auth by nextauthjs?

Get instant alerts when new vulnerabilities affect next-auth - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.3
Exploit prediction
EPSS 0.3%
SSVC
No known exploit

Description

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.29.94.0.0 ≤ v < 4.10.2
Affected range stops below 3.29.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.10.2, so it looks safe — our inference, not a vendor statement
v < 3.29.9v < 4.10.2
Affected range stops below 3.29.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.10.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

3.3LOWGitHub_M
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-532

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card