CVE-2022-31175

Cross-site scripting caused by the editor instance destroying process in ckeditor5

MEDIUM
4.7
CVSS Score
Published: August 3, 2022 at 07:05 PM UTC
Updated: June 17, 2026 at 04:44 AM UTC
4 products affected across 1 vendorCKEDITOR5 Markdown GfmCKEDITOR5 Html SupportCKEDITOR5 Html Embed

Using ckeditor5 by ckeditor?

Get instant alerts when new vulnerabilities affect ckeditor5 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.7
Exploit prediction
EPSS 0.9%
SSVC
No known exploit

Description

CKEditor 5 is a JavaScript rich text editor. A cross-site scripting vulnerability has been discovered affecting three optional CKEditor 5's packages in versions prior to 35.0.1. The vulnerability allowed to trigger a JavaScript code after fulfilling special conditions. The affected packages are `@ckeditor/ckeditor5-markdown-gfm`, `@ckeditor/ckeditor5-html-support`, and `@ckeditor/ckeditor5-html-embed`. The specific conditions are 1) Using one of the affected packages. In case of `ckeditor5-html-support` and `ckeditor5-html-embed`, additionally, it was required to use a configuration that allows unsafe markup inside the editor. 2) Destroying the editor instance and 3) Initializing the editor on an element and using an element other than `<textarea>` as a base. The root cause of the issue was a mechanism responsible for updating the source element with the markup coming from the CKEditor 5 data pipeline after destroying the editor. This vulnerability might affect a small percent of integrators that depend on dynamic editor initialization/destroy and use Markdown, General HTML Support or HTML embed features. The problem has been recognized and patched. The fix is available in version 35.0.1. There are no known workarounds for this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 35.0.1
Affected range stops below 35.0.1, so it looks safe — our inference, not a vendor statement
v < 35.0.1
Affected range stops below 35.0.1, so it looks safe — our inference, not a vendor statement
v < 35.0.1
Affected range stops below 35.0.1, so it looks safe — our inference, not a vendor statement
v < 35.0.1
Affected range stops below 35.0.1, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card