CVE-2022-31157

Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library

HIGH
7.5
CVSS Score
Published: July 15, 2022 at 05:15 PM UTC
Updated: June 17, 2026 at 04:44 AM UTC
2 products affected across 2 vendorsLti 1.3 Tool LibraryLti 1-3-tool Library

Using lti-1-3-php-library by packbackbooks?

Get instant alerts when new vulnerabilities affect lti-1-3-php-library - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 0.5%
SSVC
No known exploit

Description

LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the function used to generate random nonces was not sufficiently cryptographically complex. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.0.0
Affected range stops below 5.0.0, so it looks safe — our inference, not a vendor statement
v < 5.0
Affected range stops below 5.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitAutomatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-327CWE-330

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card