CVE-2022-31090

CURLOPT_HTTPAUTH option not cleared on change of origin in Guzzle

HIGH
7.7
CVSS Score
Published: June 27, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:44 AM UTC
3 products affected across 3 vendorsDebian LinuxGuzzleGuzzle

Using guzzle by guzzle?

Get instant alerts when new vulnerabilities affect guzzle - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.7
Exploit prediction
EPSS 2%
SSVC
No known exploit

Description

Guzzle, an extensible PHP HTTP client. `Authorization` headers on requests are sensitive information. In affected versions when using our Curl handler, it is possible to use the `CURLOPT_HTTPAUTH` option to specify an `Authorization` header. On making a request which responds with a redirect to a URI with a different origin (change in host, scheme or port), if we choose to follow it, we should remove the `CURLOPT_HTTPAUTH` option before continuing, stopping curl from appending the `Authorization` header to the new request. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host would trigger removal of the curl-added Authorization header, however this earlier fix did not cover change in scheme or change in port. If you do not require or expect redirects to be followed, one should simply disable redirects all together. Alternatively, one can specify to use the Guzzle steam handler backend, rather than curl.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 6.5.87.0.0 ≤ v < 7.4.5
Affected range stops below 6.5.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.5, so it looks safe — our inference, not a vendor statement
v < 6.5.8v < 7.4.5
Affected range stops below 6.5.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 7.4.5, so it looks safe — our inference, not a vendor statement

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

7.7HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
CHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200CWE-212

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card