CVE-2022-31075

KubeEdge DoS when signing the CSR from EdgeCore

MEDIUM
6.5
CVSS Score
Published: July 11, 2022 at 08:15 PM UTC
Updated: June 17, 2026 at 04:44 AM UTC
2 products affected across 2 vendorsKubeedgeKubeedge

Using kubeedge by kubeedge?

Get instant alerts when new vulnerabilities affect kubeedge - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 1.0%
SSVC
No known exploit

Description

KubeEdge is an open source system for extending native containerized application orchestration capabilities to hosts at Edge. Prior to versions 1.11.1, 1.10.2, and 1.9.4, EdgeCore may be susceptible to a DoS attack on CloudHub if an attacker was to send a well-crafted HTTP request to `/edge.crt`. If an attacker can send a well-crafted HTTP request to CloudHub, and that request has a very large body, that request can crash the HTTP service through a memory exhaustion vector. The request body is being read into memory, and a body that is larger than the available memory can lead to a successful attack. Because the request would have to make it through authorization, only authorized users may perform this attack. The consequence of the exhaustion is that CloudHub will be in denial of service. KubeEdge is affected only when users enable the CloudHub module in the file `cloudcore.yaml`. This bug has been fixed in Kubeedge 1.11.1, 1.10.2, and 1.9.4. As a workaround, disable the CloudHub switch in the config file `cloudcore.yaml`.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.9.41.10.0 ≤ v < 1.10.21.11.0 ≤ v < 1.11.1
Affected range stops below 1.10.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.11.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.4, so it looks safe — our inference, not a vendor statement
v < 1.10.2v < 1.9.4= 1.11.0
Affected range stops below 1.10.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-400CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card