CVE-2022-2991

MEDIUM
6.7
CVSS Score
Published: August 25, 2022 at 05:24 PM UTC
Updated: June 17, 2026 at 04:42 AM UTC
2 products affected across 2 vendorsLinux KernelKernel

Using kernel by N/A?

Get instant alerts when new vulnerabilities affect kernel - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.7
Exploit prediction
EPSS 0.5%

Description

A heap-based buffer overflow was found in the Linux kernel's LightNVM subsystem. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length heap-based buffer. This vulnerability allows a local attacker to escalate privileges and execute arbitrary code in the context of the kernel. The attacker must first obtain the ability to execute high-privileged code on the target system to exploit this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 5.15
Affected range stops below 5.15, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 5.15-rc1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-122CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card