CVE-2022-29036

MEDIUM
5.4
CVSS Score
Published: April 12, 2022 at 12:00 AM UTC
Updated: June 17, 2026 at 04:39 AM UTC
1 product affected across 1 vendorCredentials

Using Jenkins Credentials Plugin by Jenkins project?

Get instant alerts when new vulnerabilities affect Jenkins Credentials Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 72%

Description

Jenkins Credentials Plugin 1111.v35a_307992395 and earlier, except 1087.1089.v2f1b_9a_b_040e4, 1074.1076.v39c30cecb_0e2, and 2.6.1.1, does not escape the name and description of Credentials parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Credentials· Jenkinsjenkins-plugin
95%
v ≤ 1111.v35a_307992395v < 2.6.1.11055.v1346ba467ba1 ≤ v < 1074.1076.v39c30cecb_0e21105.vb_4e24a_c78b_81 ≤ v < 1112.vc87b_7a_3597f6
Vendor states this is fixed in 1074.1076.v39c30cecb_0e2 (unaffected)
Vendor states this is fixed in 1087.1089.v2f1b_9a_b_040e4 (unaffected)
Affected range stops below 1112.vc87b_7a_3597f6, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.6.1.1 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card