CVE-2022-28730

Apache JSPWiki Cross-site scripting vulnerability on AJAXPreview.jsp

MEDIUM
6.1
CVSS Score
Published: August 4, 2022 at 06:15 AM UTC
Updated: June 17, 2026 at 04:38 AM UTC
1 product affected across 1 vendorJspwiki

Using Apache JSPWiki by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache JSPWiki - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 86%

Description

A carefully crafted request on AJAXPreview.jsp could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. This vulnerability leverages CVE-2021-40369, where the Denounce plugin dangerously renders user-supplied URLs. Upon re-testing CVE-2021-40369, it appears that the patch was incomplete as it was still possible to insert malicious input via the Denounce plugin. Apache JSPWiki users should upgrade to 2.11.3 or later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.11.3Apache JSPWiki ≤ v ≤ Apache JSPWiki up to 2.11.2
Affected range stops below 2.11.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card