CVE-2022-28716

HIGH
8.8
CVSS Score
Published: May 5, 2022 at 04:41 PM UTC
Updated: June 17, 2026 at 04:38 AM UTC
4 products affected across 1 vendorBig IP Advanced Firewall ManagerBig IP Policy Enforcement ManagerBig IP Carrier Grade Nat

Using BIG-IP by F5?

Get instant alerts when new vulnerabilities affect BIG-IP - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 0.8%

Description

On 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior to 13.1.5, and all versions of 12.1.x 11.6.x, a DOM-based cross-site scripting (XSS) vulnerability exists in an undisclosed page of the BIG-IP AFM, CGNAT, and PEM Configuration utility that allows an attacker to execute JavaScript in the context of the currently logged-in user. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

11.6.1 ≤ v ≤ 11.6.512.1.0 ≤ v ≤ 12.1.613.1.0 ≤ v < 13.1.514.1.0 ≤ v < 14.1.4.615.1.0 ≤ v < 15.1.5.116.1.0 ≤ v < 16.1.2.2
Affected range stops below 13.1.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.4.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1.2.2, so it looks safe — our inference, not a vendor statement
11.6.1 ≤ v ≤ 11.6.512.1.0 ≤ v ≤ 12.1.613.1.0 ≤ v < 13.1.514.1.0 ≤ v < 14.1.4.615.1.0 ≤ v < 15.1.5.116.1.0 ≤ v < 16.1.2.2
Affected range stops below 13.1.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.4.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1.2.2, so it looks safe — our inference, not a vendor statement
11.6.1 ≤ v ≤ 11.6.512.1.0 ≤ v ≤ 12.1.613.1.0 ≤ v < 13.1.514.1.0 ≤ v < 14.1.4.615.1.0 ≤ v < 15.1.5.116.1.0 ≤ v < 16.1.2.2
Affected range stops below 13.1.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.4.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1.2.2, so it looks safe — our inference, not a vendor statement
13.1.x ≤ v < 13.1.514.1.x ≤ v < 14.1.4.615.1.x ≤ v < 15.1.5.116.1.x ≤ v < 16.1.2.211.6.x12.1.x13.1.x14.1.x15.1.x16.1.x
Affected range stops below 13.1.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 14.1.4.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1.5.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1.2.2, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 17.0.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_MISCMitigationVendor Advisory
https://support.f5.com/csp/article/K25451853

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card