CVE-2022-28366

HIGH
7.5
CVSS Score
Published: April 21, 2022 at 10:41 PM UTC
Updated: June 17, 2026 at 04:38 AM UTC
3 products affected across 3 vendorsAntisamyHtmlUnitCyberneko Html

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 2%

Description

Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.6.6
Affected range stops below 1.6.6, so it looks safe — our inference, not a vendor statement
v < 2.27
Affected range stops below 2.27, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

References (3)

x_refsource_MISCRelease NotesThird Party Advisory
https://github.com/nahsra/antisamy/releases/tag/v1.6.6
x_refsource_MISCRelease NotesThird Party Advisory
https://sourceforge.net/projects/htmlunit/files/htmlunit/2.27/

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card