CVE-2022-25243

MEDIUM
6.5
CVSS Score
Published: March 7, 2022 at 09:45 PM UTC
Updated: June 17, 2026 at 04:33 AM UTC
1 product affected across 1 vendorVault

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.6%

Description

"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1.8.0 ≤ v < 1.8.91.9.0 ≤ v < 1.9.4
Affected range stops below 1.8.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-295

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card