CVE-2022-24894

Symfony storing cookie headers in HttpCache

HIGH
8.8
CVSS Score
Published: February 3, 2023 at 09:46 PM UTC
Updated: June 17, 2026 at 04:32 AM UTC
2 products affected across 2 vendorsSymfonySymfony

Using symfony by symfony?

Get instant alerts when new vulnerabilities affect symfony - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 4%
SSVC
No known exploit

Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. The Symfony HTTP cache system, acts as a reverse proxy: It caches entire responses (including headers) and returns them to the clients. In a recent change in the `AbstractSessionListener`, the response might contain a `Set-Cookie` header. If the Symfony HTTP cache system is enabled, this response might bill stored and return to the next clients. An attacker can use this vulnerability to retrieve the victim's session. This issue has been patched and is available for branch 4.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.0.0 ≤ v < 4.4.505.0.0 ≤ v < 5.4.26.0.0 ≤ v < 6.0.206.1.0 ≤ v < 6.1.126.2.0 ≤ v < 6.2.6
Affected range stops below 4.4.50, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement
v < 4.4.50v < 5.4.20v < 6.0.20v < 6.1.12v < 6.2.6
Affected range stops below 4.4.50, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.20, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.12, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-285NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card